Jump to content
Sign in to follow this  
VisualVales

Hi Everyone! Need your expertise

Recommended Posts

Hi everyone. I just bought my first bike, Yamaha XS750 Special 1978, and joined up on this forum. I'm having quite a few problem getting this thing back to it's former glory. Besides having issues with my flashers and ignition button, I am trying to find out where to connect the tach cable on the engine. Any and all help would be appreciated.

God Bless!

Brian

Share this post


Link to post
Share on other sites

Hello, the tach cable should not connect to your engine it should connect to your front wheel near the brake, then into the tachometer. Hope this helps.

Thanks.

Share this post


Link to post
Share on other sites

Hello, the tach cable should not connect to your engine it should connect to your front wheel near the brake, then into the tachometer. Hope this helps.

Thanks.

:huh: that's where Mr speedo goes, he's the one that measures your road speed. Mr Tacho might live front top of the cylinder headas its nice and warm there because he likes to sleep comfy.

this, BTW is the new members area NOT the workshop <_<

moving this thread....

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...