Jump to content

sr125 running issues


Recommended Posts

Hi there i've just bought a 1999 sr125 it has stood in a garage for 19 years,

cleaned out carb replaced air filter starts fine with choke (heater) ticks over butwon't rev very well, tried pilot screw no luck, 

any clues please.

Cheers Keith.

Link to comment
Share on other sites

  • 3 years later...
Do you want an ad-free experience? Join today and help support the Yamaha Owners Club.

Hi Keith,

Had similar issue with mine. I had to play with the pilot screw and idle screw a lot before she was reving ok. Started at the spec setting and then tweaked out from there until she idled and rev'd smoothly. Make sure she's warm before making adjustments. Haynes manual is invaluable. 

Hope that helps. 

Cheers,

Clive

Edited by Clive_D
  • Thanks 1
Link to comment
Share on other sites

Hi Clive, Keith is what we call a One Hit Wonder! He only made one post (the number 1 above his current bikes indicates the number of posts he made) This was some three years ago ....never to be seen again.!

He may well have a valid reason for never posting again, but there are plenty of One Hit Wonders who we never see again.

Nonetheless , you rounded off this topic, so i think this topic can be closed off and locked to further posts.

You get a thanks from me for taking the time to write. 👍

Link to comment
Share on other sites

  • drewpy locked this topic
Guest
This topic is now closed to further replies.
 Share

  • Who's Online (See full list)

    • There are no registered users currently online
  • Recently Browsing

    • No registered users viewing this page.
×
×
  • Create New...