Jump to content
Sign in to follow this  
Fishfearhim2

TW125 carb / running prob

Recommended Posts

Hi all, I am a newbie to this site. I was hoping that someone may be able to help me a problem that's been causing me to pull my hair out, and to be jonest I can't afford to lose any more! I bought a 2003 TW125 for my son. When we went to buy it, it would run and rev but not tick over, (at this point we should have walked away). The seller said it was probably a blocked slow running jet due to lack of use and that some carb cleaner in the fuel with a long run should sort it. Well we bought the bike and did that, but nothing changed? After checking for splits and air leaks on the inlet rubber, I removed the carb, stripped, cleaned and blew compressed air everywhere (it was actually very very clean inside). I also renewed the air filter and spark plug. The spark is strong, the compression is good and the fuel flows freely from the tank. With the carb back on the bike it would only run on full choke and not at all if revved. Thinking it was fuel stavation I adjusted the float height to allow more fuel to sit in the bowl and raised the needle 1 groove from it's middle position, result was not much better. It would now run at fast tickover without choke when warm but would die if revved? Now convinced it was a carb problem I bought another from a breaker on FleaBay. I couldn't believe the state it was in when it finally arrived, caked in mud and grease and full of shite. I took it a local garage and they stripped checked and ultra-sonic cleaned everything. It came back looking like new. I fitted it to the bike which started a ran at very high rev's. After a bit of adjustment with the mixture screw and throttle stop the bike would tick over but cut out when revved - sounds familiar! That's it, I'd had enough. The bike with both carbs was taken to a local bike shop. The above story was told to the mechanic. The next day the bike mechanic spent over 7 hours trying to get the bike to run correctly. He concluded that both carbs are faulty. The bike will now run and rev but only on full choke when cold, and cuts out when hot. Has anyone experience a similar problem? Is there a carb from another bike that can be fitted? I did notice when calling breakers trying to locate another carb that this bit is often the first to go, so I assume they must be required by people having problems like me?

Any pointers, advice and hair transplant offers will be greatfully received.

Share this post


Link to post
Share on other sites

A "hello" in the newbie section would possibly get you some help.

Share this post


Link to post
Share on other sites

yeah i can see why its so confusing...still looks like carb to me though. when you stripped the carb can you say without question the jets were clear, ie you saw daylight looking through the bores?

Share this post


Link to post
Share on other sites

Yes, the jets were clear. I had a local garage clean the whole carb in & out. The bike shop I took it to said the wouldn't run at all on the standard carb settings - that's on both of them? I feel sure this must be a fairly common problem as when someone breaks a TW the carb is usually the first item to be sold. I'm wondering if there's a better carb from another model that could be used?

Share this post


Link to post
Share on other sites

There could be a common problem with the carbs. Is this the carb with the diaphragms? One of these could have a pin hole in it - they are bl00dy expensive. Also I would assume that it is not a US import as come of there (Californian) ones have an extra "emissions" gubbins on them. Alos check the tank fuel pipes and petcock for blockages.

Share this post


Link to post
Share on other sites

It definitely sounds like the carb. What colour is the plug? Have you checked that the air filter is clean and have you tried running it with the airbox and exhaust off?

Share this post


Link to post
Share on other sites

Also look at the rubber carb mountings for splits.

Not sure if you have seen this site but some interesting info. It is in German with dodgy English translation but look at the Carb link on the left and the accessories. LINKY

Share this post


Link to post
Share on other sites

.................. The bike will now run and rev but only on full choke when cold, and cuts out when hot. Has anyone experience a similar problem? Is there a carb from another bike that can be fitted? I did notice when calling breakers trying to locate another carb that this bit is often the first to go, so I assume they must be required by people having problems like me?

Any pointers, advice and hair transplant offers will be greatfully received.

Full choke when cold is normal

Take the filter out and see if it still cuts when hot

Share this post


Link to post
Share on other sites

Hi, yes it still cuts out when with the air filter removed. I renewed the filter and plug, neither made any difference. I have tried running the bike without the air box hot and cold buy not without the exhaust ?? The carb mount isn't split and I put some RTV on the mating faces upon reassembly just incase there was a slight warp (which i'm sure there isn't). I'll give it a go without the exhaust (been looking for an excuse to annoy the neighbours !)

Share this post


Link to post
Share on other sites

Hi, even when cold and running on full choke the engine has to be revved, as if it's left to idle for more than a few seconds it'll cut out. When it does cut out it will not restart immediately but will after about 10 seconds. I'm convinced it's a slow running problem with the carb. I found a web site that detailed the stripping of this carb. It was useful to confirm all the parts etc were present and correct on mine. I also found an American site where someone had exactly the same problem as me. He documented and followed all the good advice forum members gave him. After spending 3 weeks and a $150 he took the bike and carb to Yamaha and they couldn't fix it! He ended up curing the problem with a second hand carb. Well, I've done that, so I guess I've two faulty carbs. This carb is made by 'Teikei' model MV28. I'm now planning to scour local bike breakers a see if I can get another carb that'll fit?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...