Jump to content

yamaha yb100 electrical problems


sdotb
 Share

Recommended Posts

hi all I bought my bike a couple of days ago and basicly need abit of advice.

my bike starts and runs nicely but my break light and indicators don't come on but my head light does when the bikes running itself so if anyone can help itl be much appreacated

  • Like 1
Link to comment
Share on other sites

Do you want an ad-free experience? Join today and help support the Yamaha Owners Club.

I think you will find that the break light and indicators require the battery but ignition and head light does not. I would be checking the battery and main fuse. Just a guess.

Link to comment
Share on other sites

Generally on these small bikes the headlight runs direct from the alternator so will only light when the engine is running. The others run from the battery and if the engine is running then the alternator will usually supply enough power to run them but when the engine is stopped the battery needs to be charged at least partially. It sounds to me that the alternator is working but the battery is dead. The battery is the device that holds the alternator voltage at 6 (usually) or 12 volts and if it is dead the dc voltage, even with the engine running, can be held low which may be why the horn is not working. Check the battery voltage when engine is running and also not running. There should be a main fuse in the battery line somewhere. Depending how the electrics are wired it couls be the fault. You haven't said if you checked that yet. You may have 2 problems. Maybe the horn is also faulty.

Link to comment
Share on other sites

As fil77 has said above you should get the neutral light come on with the ignition on and without starting the engine. Has the battery got enough fluid in it i.e distilled water topped up to the upper level on the side of the battery and as above check the fuse which you should find inline on the Red wire near the battery.

Link to comment
Share on other sites

I think you need to get the battery checked. It could be the problem and certainly sounds like it is stuffed. If your neutral light is comming on when the engine is running but brake light and indicater don't is a bit of a worry but they do require more juice than the neutral light and certainly could be caused by a dead battery loading the alternator down. I am guessing here as I have no knowlege of your bike or it's electrics only some old experiences from my previous dirt bikes. Haven't had one in years.

Link to comment
Share on other sites

  • Moderator

the neutral light only comes on when the engines running and my batterys had it its about a 3 year old rotten thing lol would that be why brake light and indicators wont work then?

Yes it would seem that way, a multimeter check would be a good thing but something tells me you havent got one, you should get one they are so cheap nowadays ;)

Link to comment
Share on other sites

don't even no what a flasher unit is or what it looks like lol anychance any of u no what the tapping could be its at the bottom of the piston ? im thinking it could be the cranks seals?

Tapping from the bottom of the piston is most likely big end bearings gone. (what happened to my bike) only way to find out whats gone is to take off the barrel grab hold of the con rod and pull it up and down, if it moves and clunks then you need new bearings / shells depending what they have, also if the bikes been running with shagged bearings for too long you may have done damage to the crank shaft and either need a new one or get the old one re ground with new shells

Link to comment
Share on other sites

  • Moderator

Before you do anything else, change the battery. It is knackered. At this point tell us if you still have any issues with the electrics. Indicators and brake lights use power from the battery, which you don't have. Don't mess with anything else electrical until you do that.

As for the tapping, the first thing is to check the tappets. There are exhaust and inlet tappets on the bike and these are easy to get to and adjust. Use the search facility on the forum as the method and measurement of these have been posted many times.

Both the battery change and tappet adjustment are very easy jobs. Once these are done, and if there is not difference, then things get a little harder. You should be able to change the battery and adjust the tappets in less that 2 hours with limited mechanical knowledge. About 15 minutes once you are familiar with the bike.

Link to comment
Share on other sites

Hi

I believe the YB100 is a two stroke; a bit like a ‘Fs1e’ on steroids, surely it does not have, but what do I know? ‘Tappets’ the crank brgs could be worn allowing the motor to make a knocking noise. The small end brg and or the piston could be worn in the bore also causing a knocking noise,

My DT was tapping slightly this turned out to be the crank shaft main brg’s,

Also I believe the crank on this bike is a pressed together item and has roller brgs on the con rod ends and a ball race brgs on the crank main brgs

I agree the battery is probably at fault for the main electrical faults, if you do try to charge it don’t use a car charger buy a proper bike 6v battery charger, car chargers push out too many amps even if switched to 6 v,

Link to comment
Share on other sites

  • Moderator

Ops. It is. For some reason I was thinking SR. No tappets then. At least the engine is easier to work on.

Note to self - read the question first.

You will need to get the head and barrel off to take a good look and have a wiggle.

Link to comment
Share on other sites

yeah the batterys had it will get round to replacing it somepoint this/next motnh as its not on the road and as for the tapping think its just the small end bearings will look further into it at somepoint tomorrow wether I can get my hands on a c spanner cheers people

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Who's Online (See full list)

    • There are no registered users currently online
  • Recently Browsing

    • No registered users viewing this page.
×
×
  • Create New...