Jump to content
Sign in to follow this  
Hotwheels

Clutch drag in brand new WR250

Recommended Posts

I've bought a brand new 2007 WR250F last weekend - running it in gently around the lanes and it's developed very bad clutch drag after about 20 miles. Took it back to the dealer who changed the oil and said it would be fine. However after another gentle 23 miles we're back with very bad clutch drag, i.e can't find neutral with the engine running, also bike creeps when in gear and clutch engaged. Supposed to be racing it on Sunday, any ideas, anyone? I'm desperate! Obviously it'll have to go back to the dealer again (another 3 hour round trip) but he doesn't seem to have a clue!

:(

Share this post


Link to post
Share on other sites

Clutch drag can also occur when too heavy an oil is used but if thats been changed then that kinda rules that out :unsure:

Share this post


Link to post
Share on other sites

poss warped plates!!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Who's Online (See full list)

    There are no registered users currently online

  • Recently Browsing

    No registered users viewing this page.

×
×
  • Create New...