Jump to content

No Spark on SR125


TMC
 Share

Recommended Posts

Hi, 

 

I've just brought a 1999 SR125 and I have no spark. I have fitted a new spark plug, coil and a new battery.

It has power to the coil and it has good earth and what an I missing? 

 

Any help is appreciated 

 

James 

Link to comment
Share on other sites

Do you want an ad-free experience? Join today and help support the Yamaha Owners Club.

Faulty engine kill switch?, Presumably it has one on the handlebars?

Also worth checking the wire that goes to it too, if it's grounding before it gets to the switch, it won't matter how good the switch is if the cable has lost its sheath and the wire is grounding enroute.

(I had something similar happen to me with my 400/4 one Christmas Eve!, unbeknown at the time, the cold weather had made a cable brittle and had exposed the wire which was grounding next to the steering head, just wouldn't start.... long push home for something so simple!)

Link to comment
Share on other sites

  • Moderator

Same for me, riding to work and he kill switch wire had touched the exhaust and melted to it. 

Long push for something i could fix at the side of the road, didn't even need tools as it was obvious as soon as i pulled off the lh side panel. pulled the wire off the exhaust and she lit right up.

  • Like 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Who's Online (See full list)

    • There are no registered users currently online
  • Recently Browsing

    • No registered users viewing this page.
×
×
  • Create New...