Jump to content
tusticles

78 xs750SE Headlamp Issue

Recommended Posts

I've got a 78 xs750SE. 4 weeks ago my regulator rectifier died.

I replaced it with this one  and the charging system started working again however I noticed that my headlight no longer works. 

All other lights/turn signals work properly. Any thoughts or ideas on where I should start testing/has anyone else run in to this issue? 

The original RR, had a three prong connector on the smaller of two connectors and the new ESR310 Regulator/Rectifier only has 2. I emailed them and asked about it but they said "That 3rd wire is a ground.  On the OEM it is intended to be a ground designated only for the regulation circuit to use, the other ground is originally dc output's connection to ground.  The ESR310 has a combine reg/rect circuit and shares one ground. Your bike should not have any shared ground connection between you lights and what was previously the regulators ground connection, but maybe you did and this is the cause of your problem."

It's odd that it happened after the RR replacement. If you think it's just the headlamp that has burned out (doesn't look like it), any recommendations on finding a similar original headlamp?

Share this post


Link to post
Share on other sites

What voltage  you getting at battery, [engine running 3000rpm] ?,,, is the bulb blown

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...