Jump to content

2009 YBR injection running rough at low revs


Recommended Posts

Hi all,

2009 YBR 125 fuel injection.

been having some issues, firstly my bike wouldn't start in the heat so changed the fuel pump and now she starts in 35 degrees in the sunshine which is a winner and the pump sounds really strong. 

Next I discovered it keeps cutting out at low revs which is annoying at traffic lights or going to pull off etc, now it's just running rough as toast but when you give it some revs and ride it above 5k it seems fine. It's like it's just misfiring so it's had a new spark plug and the air filter is super clean. It's almost like it's hunting and the throttle response is abysmal.

I'm going to check the coil/HT lead, injector check (just visual I assume is all I can do) and valve clearances. Is there anything obvious I should check, I mean it's a simple engine but it's driving me nuts. 

 

Thanks in advance all

Ian

Link to post
Share on other sites
  • 1 month later...

The fuel injected YBR's have a fast idle system which is designed to run the engine at elevated rpm's for the first five to fifteen minutes or so of stop-and-go riding  (depends on current temperature etc) and then backs off to run normally. Normal is 1300 to 1500rpm. When I took mine to a garage for servicing, they started it up and it was reading too high because it was cold and started on the fast idle speed (2000+ rpm) so they wound back the idle to what 'normal' was. Consequently when I got back on the bike to ride home, ten minutes later it slowed the idle speed down and died at the traffic lights. After a couple more stop and stalls I figured out what was happening and had to rev it to keep it going, which I'm sure made me look a bit of a tit. After adjusting the idle back via the idle speed adjuster (right side of the throttle body) it worked perfectly. Make sure it's in neutral first - clockwise to increase idle, anticlockwise to decrease. It's a good idea to check the idle speed periodically and also after changes such as spark plugs, air filters, valve clearances etc. - pretty much any change to fuelling or exhaust. If this doesn't work, the fast idle solenoid would be another place to check.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...