Jump to content

Couple of slight issues- 2010 yz450f


Recommended Posts

Hey guys, after sorting out my last couple of issues with the bike, 2 more have sprung up.

Number one is that every now and again the bike would bog down like it had no fuel, even though it did. This used to happen once it had around 1/4 of a tank, filling up would fix the issue. Then it happened slightly more frequently even whilst full, seemed to be when the bike was hot. Today, it cracked the sads big time and I barely managed to baby it back to the ute.

Then, after a trip home I decided to try and ride again to see if it was still carrying on. Nope, ran great, pulled hard and revved out happily. My guess is fuel pump but can anyone confirm?

This leads me to the 2nd problem. Flying down the track, top of 4th gear, all of a sudden the bike free revs like it's in neutral, try and select a gear, they were all there but the bike just free revved.

Look down to see the nut holding the drive sprocket on has fallen off and the sprocket has come off the spline, also spraying oil everywhere in the process.

Is there just a seal behind the cover the drive sprocket sits on thats caused this? Obviously the nut is to blame but will the oil be spewing out because its stuffed a seal in the process?

Thanks in advance

Link to post
Share on other sites

yes they should be a drive crank seal, but when the sprocket on it helps too keep the seal/collar in place...put the sprocket back on see if the leak stops....if it dosn't then you may need a new seal

the other problem does sound a bit like a fuel problem, but electical an coils can do the same as you described too..

i'd start with the basics, like..... fuel lines, vacuums, breather pipes ect ect an go from there

Link to post
Share on other sites

Before we go any further, my bike is fuel injected so no petcock to play with, and I only have one fuel line.

It might be worth noting that the day it played up big time, earlier that day when it was running better, it didnt feel like it had anywhere near as much pull as usual but it still ran okay. Im leaning toward fuel issue but at $500 for a new pump I want to make damn sure thats actually what it is

Link to post
Share on other sites

Also, just had a thought, I cant exactly recall but I THINK these problems started after putting a new breather on the fuel cap so that could be it? Perhaps when im filling the bike up after this problem has occured its releasing the pressure and solving my issue

Link to post
Share on other sites
  • Moderator

Also, just had a thought, I cant exactly recall but I THINK these problems started after putting a new breather on the fuel cap so that could be it? Perhaps when im filling the bike up after this problem has occured its releasing the pressure and solving my issue

that would do it, glad you spotted this before lashing out $$$'s, best get cheching the venting

Link to post
Share on other sites

Going to check it tomorrow, the breather line has some fancy one way valve in it to let positive tank pressure out without letting fuel spill out. In theory its a good idea but what I suspect is happening is my tank is getting negative pressure, locking this valve shut thus getting an air lock.

I guess having a fuel pump instead of gravity fed carby would also make it worse. Fingers crossed this is the problem.

Link to post
Share on other sites
  • Moderator

Going to check it tomorrow, the breather line has some fancy one way valve in it to let positive tank pressure out without letting fuel spill out. In theory its a good idea but what I suspect is happening is my tank is getting negative pressure, locking this valve shut thus getting an air lock.

I guess having a fuel pump instead of gravity fed carby would also make it worse. Fingers crossed this is the problem.

yep try taking out the spill valve see if it cures it, incidentally...is there a right way up for these valves? just wondering

Link to post
Share on other sites

Yep there is a arrow on the valve and it should point away from the cap.

The other thing you can check is fuel flow/volume when it acts up ,you would need to disconnect the fuel line and jump the relay to feed the fuel pump and see if your getting a good flow of fuel about 1 lt in 1 min.Then you would need a fuel pressuer tester to install in line and check the amount of pressure the pump can deliver if you have 15lb injectors then you need 20 lbs of presuer ,but that will be in the manual min and max fuel pressure.

Link to post
Share on other sites

Yeah the breather is installed correctly but I just have a feeling thats the problem. Fuel tanks need to breathe both ways and that one way valve I think is stopping it from breathing in so the more I ride the more of a vacuuk lock im getting. I hope its the problem.

Anyone heard of anything similar?

Link to post
Share on other sites

Sure old gas caps get pluged on street bikes and don't vent.

Next time it does this open the cap see what happens or do all the test's on the fuel system , that is only way you will konw for sure.None of it hard to do and dosent take long,BUT you need all the tools.

Look on the tube lots of ways to make you own tools for the fi system,a hose with the right fittings and a pressure gauge in the middle is all a pressure gauge is.

Welcome to owning a FI bike,

Link to post
Share on other sites

Okay, new day new headaches :/

Took the bike for a ride just before and the fuel issue seems to have corrected itself for now. But it only used to do it every now and again so I don't know if its 100% fixed yet, time will tell.

My main issue is the bikes leaking oil from the drive sprocket where I put the new seal in. Now I was pretty sure I did it all correctly, is there a certain trick or procedure to doing it that I've missed?

Perhaps I haven't done the nut back up tight enough, would this cause the leak?

Thanks again.

Link to post
Share on other sites

No " the nut tightens the sprocket against a shoulder on drive shaft , not the seal, may have damaged the new seal, :eusa_think:

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...