Jump to content
Sign in to follow this  
51st state

yamaha xt125r dash problem neutral light on permanently

Recommended Posts

2008 xt125r , neutral light stays and dash also flashs up "endr" and "ntord" when ignition is off, when ignition is turned on the neutral light gets brighter and dash goes off, have tried all solution of diconnecting battery and then turning on when "endr" flashes up while pressing "mode" button on left switchgear but still the same! i have noticed the neutral light is dimmer when ignition is off, if i put it in gear the light goes out and the dash stops showing endr and ntord, is this a wiring/earth problem? has anyone solved this? or is it just the dash problem?? another thing it does if left diconnected for an hour , when i reconnect the dash all the numbers etc light up on the dash like a system test so lcd screen must be ok, it then shows RD 35-06 before showing "endr" and "ntord" any idea what RD 35-06 means??

Share this post


Link to post
Share on other sites

nobody got any answers ?

have seen the thread by "grouch" and his cursed xt125

any help would be appreciated

cheers H

Share this post


Link to post
Share on other sites

Sounds like a fault code. Easiest answer is ask a yam dealer.

This is why i like my older stuff.

Share this post


Link to post
Share on other sites

Check the owners manual mate, I'd put diamonds on it that the answer on how to set the digital clocks up is in there, the "endr" from what I've read about is for the 'R' or the 21" front and 18" rear wheel Enduro set up, as opposed to the 'X' or Supermoto 18"/17" front, 18"/17" rear set up.

Share this post


Link to post
Share on other sites

Nevs right its the tyre sizeing for the speedo

this is happening because you have a bad connection to the battery

or broken wire to the battery which is causeing it to reset

trust me sort this sooner rather than later iv had this problem

otherwise it can do 2 things new speedo or loom

speedo costs 200+ so check your connections

if this fails check the connector to the back of the speedo

XTs have SHIT speedos this is fact

if it dies completely

replace it with an aftermarket like trail techs vapour speedo

message me if you get stuck

Share this post


Link to post
Share on other sites

thanks for the replies, i understand that the endr and ntrd are the R and X models with different wheels sizes , the battery connection seems fine as the starter starts the bike easily, i have also checked the connections to the back of the speedo which are clean and tidy , i have also done some tests with a multimeter to the connection and have found it has a permanent 12v feed even when turned off and is somehow linked to the neutral light, if i unplug the neutral light sensor the bike will not run so it also cuts the spark , any ideas?

i've also tested for ohm readings and volt reading on the dash connectors while using indicators , main beam etc and found that the readings change so feed to the dash looks to be working correctly and pointing towards a faulty dash??

i will phone a dealer and see what they have to say about the 36-05 that flashes up, my guess is they will ant me to take it in and collect some money!

there are some good after market lcd clocks on the internet at very prices

Pritchard XT what problems have you found with loom? all info appreciated

cheers H

Share this post


Link to post
Share on other sites

Can you open the console. Check the CSOM battery it sound like that could be faulty as it seems to be running flat. If you get it open, check for water, rush and anything that could cause a short circuit.

My guess would be there is water in the clocks.

With the sensors, generally you can make the connection with a length of wire to bypass it.

Share this post


Link to post
Share on other sites

speedos shoot mate best get a new one there around the £200 mark for new one from yamaha

ive managed to fit an aftermarket one only took hour and half

the XT's looms to short in general over the whole thing

the positioning around the steering stem plus the length cost me two looms all ready

2nd time shorted out the speedo and when I cracked it open

there was a nice circle of black where a component should have been

remember you can still pass an MOT without one buy its against the law to be on road with out

and you don't need the twat lights either this may give you an advisory

http://www.ebay.co.uk/itm/New-Trail-Tech-Stealth-Vapor-Speedo-Motorcycle-Universal-Aircooled-Speedometer-/140943040891?pt=UK_Motorcycle_Parts&hash=item20d0dc217b

that's what im using at the moment works fine

Share this post


Link to post
Share on other sites

I'm looking at putting an aftermarket speedo on my sons xt125x (2009). Found all the wires for lights, indicators, reserve tank but can't figure out the neutral gear lamp. Anyone got any ideas

Cheers all

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...