Jump to content

YBR stall's when it says its in neutral ?


NewberzYBR
This post is 4973 days old and we'd rather you create a new post instead of adding to this one. You can't reply in this post.

Recommended Posts

hi sorry that the first quistion is a workshop quistion but when my bike is in neutral and the light comes on to say it is but half the time its not in neutral its in first and then obv stalls was just woundering if there is any reason for this or if anybody else's ybr does this any help be great cheers :)

Link to comment
Share on other sites

Do you want an ad-free experience? Join today and help support the Yamaha Owners Club.

hi sorry that the first quistion is a workshop quistion but when my bike is in neutral and the light comes on to say it is but half the time its not in neutral its in first and then obv stalls was just woundering if there is any reason for this or if anybody else's ybr does this any help be great cheers :)

Thats a wierd one, i cant help !

Link to comment
Share on other sites

  • Moderator

mine (xs400)does that occasionally, its a contact on the other end of the gear change drum that must get a bit of swarf or oil to create a contact.

Mind you, it is 32 years old B)

Link to comment
Share on other sites

  • 3 weeks later...

How old is your oil? Many users wrote that shifting became better after the change of the oil.

Greetings, Martin

Link to comment
Share on other sites

How old is your oil? Many users wrote that shifting became better after the change of the oil.

Greetings, Martin

good answer! most gear problems are caused by bad oil, could be a case of the contact for the neutral switch is engaging but the gears arnt slipping in, just do a complete oil change (drain, fill, run, drain, fill) then that should sort it out. for flushing just get some cheep (ish) 10w40 then after u drain it fill it up with the good stuff :D

(dont ask me what oil to use as i dont know :P lol)

Link to comment
Share on other sites

How old is your oil? Many users wrote that shifting became better after the change of the oil.

Greetings, Martin

Sound advice. Had similar problems with mine when first bought it, plus couldnt easily engage neutral from 1st or second, tended to shift straight through or stick in. Changed oil for type specified in owners handbook, immediate improvement. Got to be right type of oil though.

Ray

Link to comment
Share on other sites

hi sorry that the first quistion is a workshop quistion but when my bike is in neutral and the light comes on to say it is but half the time its not in neutral its in first and then obv stalls was just woundering if there is any reason for this or if anybody else's ybr does this any help be great cheers :)

I notice by your posts that the bike is a brand new 2010 .

So if there is really anything wrong ? <_< you should take it to the dealers , as for oil changes I shouldn't think you should be bothered as ,they will do it on first service,thats when its over 6 month or done 600 miles, which no doubt it says in the owners manual :mellow:

Link to comment
Share on other sites

  • Who's Online (See full list)

    • There are no registered users currently online
  • Recently Browsing

    • No registered users viewing this page.
×
×
  • Create New...