Jump to content
Sign in to follow this  
Canada

75 Chappy NO START

Recommended Posts

I just got an old chappy 50cc.

I cleaned the carb really well, replaced the spark plug.

When I kick it over I HAVE SPARK! ANd there is good compression. However it does not start? I even tried pouring a little bit of gas directly into the carb. Nothing. I tried taking oit the spark plug, puring  a tiny bit if gas in there and quickly  replacing the plug and kicking it over......I thought that would at least ignote that little bit of gas, but nothing?

I DO NOT have a battery installed, the toggle kill switch on the right side handle bar I tried all 3 positions and no change.

I am surprised, especially if there is spark and fuel in the chamber, should it not at least ignite that fuel?

Do I need battery installed to start it?
Could it be my kill switch?

Thought and thanks

Shawn

Share this post


Link to post
Share on other sites

Have you tried a new plug. Yours may be sparking outside the engine but failing under load. Doubt it will be the kill switch as you wouldn't get a spark inside or outside the engine

Probably better sticking a battery in place to give it a boost

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...