Jump to content
Variomatic

XS750 tacho drive chewed itself

Recommended Posts

My neighbor has an XS750, the tacho stopped working two days ago and he asked me to have a look, when I got there this morning I took the cable off and found out it was totally seized (Like not from rust, from fraying and tangling itself up it seems), put on the cable he bought as a replacement and it still didn't work, on closer inspection we found the drive gear wasn't turning. I took the valve cover off and to our horror we found out that the drive gear has totally eaten itself, the bevel drive on the camshaft is basically gone. 

Now the real problem. All the shavings seems to have been swept into the depths of the engine. Do you think it's game over? I'm guessing a couple of extremely frequent oil/filter changes might save it but I'm not really sure. What do you guys think?  

Share this post


Link to post
Share on other sites

Engine flush with diesel or some such first then (assuming it's magnetic swarf) a new magnetic sump plug, you really should strip it but you might be lucky and get away with it. Otherwise you could just drop the sump and clean the lumps out..!

Take the filler plug out have the drain plug out as well and just pour oil in and straight out into another can then swap can's and keep going till you have no swarf left coming through. Try a magnet, one of those on a telescopic stick, and try to remove anything from the top of the engine via the oil ways. Good luck.

Share this post


Link to post
Share on other sites

Plenty of flushing and a magnetic plug as above. You might be lucky, presumably it's been on the way out for a while so might only be small pieces not big lumps

Share this post


Link to post
Share on other sites

Compression on the cylinders (left to right) is 105-130-135 (and yes the valves are sealing and the clearances are right) so the engine was basically fucked anyway but it'd be nice to not have to do that just yet. I tried flushing it with diesel like slice suggested, managed to get a metric fuck load of swarf out but I think it wasn't enough because since it happened the engine has been sounding really sketchy, this morning it sounded ok, but after a short spin it doesn't sound happy, and for some reason the clutch has started slipping (although we think this is coincidental) 

We're thinking about ripping it apart and trying to make one good engine from it and a spare engine we found on fleabay fuck a fucked gearbox, not sure though. Might be up for sale soon if anyone wants a really fucked XS750? :lol:

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Who's Online (See full list)

    There are no registered users currently online

  • Recently Browsing

    No registered users viewing this page.

×
×
  • Create New...