Jump to content

YBR 250 — Foul Spark / Jumping/Lagging in 3rd


Recommended Posts

Hello, I've tried and tried again to get the search working for me, but I failed miserably. So I'll try and see if any of the pros here can help out for a second.

My girlfriend got back into motorcycles, we found a YBR 250 for her (fuel-injected, 40k miles, pristine visual condition), but now she's having issues in 3rd gear and up with the bike jumping a bit (I've noticed this as well, but I figured it may be my non-female weight and abused throttle-hand). Previous owner changed oil and oil filters (mechanics did) recently.

Checked the spark plug, black, sooty but not oily. Seems to run rich. Thought the carb needs inspecting, realised it's actually FI (you see how not qualified I am). 

I then checked air filter (see photo), it's not clean, clean, but also not completely covered in dirt. We'll probably order a new one (don't have the cleaning supplies here).

But I still have my doubts the air filter caused all of this? Any other YBR 250 owners here, or someone with actual mechanical knowledge? Do you think this is clearly the air filter causing the ECU to richen this up, or could that be anything else?

 

Thanks guys, I promised her this will be fun, and now just as we're getting her back up to speed this comes up.

Screen Shot 2017-06-16 at 11.07.47.jpg

Screen Shot 2017-06-16 at 11.08.17.jpg

Link to post
Share on other sites
  • Moderator

Easiest test first. Ride it without the filter and see what happens.

Next one is a question. Does it smoke at all.

Link to post
Share on other sites

Thanks for the quick response, you reckon it's fine to run it without a filter (for a brief test ride only I mean)? Not entirely sure what may be pulled into the engine there? But that would at least sound like the most straight-forward test of all indeed. 

Smoke, not really. I'll try again and see if I can detect something — smelled a bit like burned plastic last night, but not sure if that actually had anything to do with it at all (two motorcycles, may have touched boots to exhaust or whatever)

Link to post
Share on other sites
  • Moderator

Yes dont go touring France but a short ride along a road you use a lot so you know how the bike normally feels.

It will make it louder. Its one of the less obvious air filter jobs, silencing the intake noise.

 

Link to post
Share on other sites

Just took out the air filter, tried it again and if anything, it may have gotten worse even (also in 2nd gear, serious jumping back and forth). Seems to happen more in lower revs, when throttle is kept constant. 

Bike always fires up perfectly. Idle speed is 1.5k which seems perfect. Battery is new, and measured (also under load), and perfect.

I did notice quite a petrol-smell today, may have been other things on the road, but just road it for a bit and it kept following me it seems. Spark is brand-new.

Any other ideas?

Link to post
Share on other sites
  • Moderator

Me. Im going with a leaky/worn injector or a compression issue. Have you checked its a really nice bright spark.

The bike running worse means the fi detected the change and compensated adding even more fuel. Componding the problem but also focusing it too.

 

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Who's Online (See full list)

    There are no registered users currently online

  • Recently Browsing

    No registered users viewing this page.

×
×
  • Create New...