Jump to content
Sign in to follow this  
ahaywood93

dt athena 170 still no spark

Recommended Posts

i was told by a actual bike mechanic that his tested my generator and thats giving off the right readings and his checked all the wiring, earths, kill switch and side stand switch, his tested the coil even though i had only just had a new one on and thats fine then pretty much the only thing he couldnt test was the cdi but everythink else i can think of was fine so i ordered a cdi friday from elf england £239 not bad it came today and it still not sparking i cant think what else it can be

Share this post


Link to post
Share on other sites

i was expecting it to be somthing like £500 as a new clutch is nearly 450 but 239s not bad but it still wont spark :(

Share this post


Link to post
Share on other sites

It last ran when I blew the old 125 up and it destroyed the top end and bottom so I got the 170 kit put it on and it hasn't sparked since I built it and put everything together

Share this post


Link to post
Share on other sites

This might sound silly but is the coil grounded and has power,it won't work unles it is.

at this point you have to go backwards and find what you did wrong The proper way is to follow the flow chart in the manual.

1st is to replace spark plug ( i'm sure you tried that)

2nd is to check every connection in the ignition system.

3 engine stop switch'and clutch saftey open and closes(test with a multi meter set on ohms scale,will have minimal resistance in run and infinate off)

4 Check coil ( done as you have a new one)

5 Check pick up coil and charging coils (Pick up coil sends signal to cdi to time the spark,no signal =no spark charge coil gives the juice)

6check netural switch

If all the above is good then and only then the cdi is at fault.

Sounds like step 2 has been over looked or the netural switch,possibly when rebuilding the motor you buggered it. Will it crank ove with the starter? And did it before rebuilding?

Share this post


Link to post
Share on other sites

Did your mechanic warm the generator and look for fluctuating readings?

Share this post


Link to post
Share on other sites

As already mentioned, check the kill switch, mine always gets stuck and I have to bang it on and off a few times, then the bike will start...

Share this post


Link to post
Share on other sites

Well got it running yet?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...