Jump to content

Craig2380

Free
  • Content Count

    10
  • Joined

  • Last visited

Community Reputation

4 Neutral

About Craig2380

  • Rank
    Member

Previous Fields

  • Current Bike(s)
    Dragstar 1100a
  1. Hi all Touch wood. Changed regulator rectifier and all been good. So next thing I am looking at is getting it sprayed Matt black. Are there boy legal things you can do to exhaust to make sound better or is it a case of just buying another system?
  2. Yes it was charging fine. Meter tested. And was new battery. I have found how to check rectifier and stator now so will check that tonight. Very annoyed with people who sold it me. They must have known about all these faults. I am pretty sure there is no such thing as sold as seen. Think I read somewhere that everything you buy know you are covered by consumer rights? Anyway that's for another forum.
  3. Hi guys. After some advice. After buying my bike a few days ago changing the battery only to find it was alternator not charging removing all connectors and cleaning them to find it was charging I have now just been let down again. Battery completely flat. No lights on or anything just normal riding in day. Had to rush it a mile to some friends house. Does anyone have any thoughts?
  4. http://http://i1030.photobucket.com/albums/y365/craigdenver/Mobile Uploads/Screenshot_2016-03-25-19-23-00_zpsvc7fl6ql.png Thought I would upload a pic
  5. Had a look at her yesterday. It would come to light that neither ht lead was pushed on properly. The spark plug gaps were almost none existent and the air pipes. From collection box and to air filter were not on securely. And the alternator was not charging. After cleaning the connectors that is sorted. Now its running loads better! Going to change plugs do oil and filter then get carbs cleaned and balanced. She needs a paint job so will be on the look out for ideas.
  6. Update. I put a new battery on her today. Set the spark plug gaps correctly. Pushed the ht leads on properly as they were on loosely. Cleaned the alternator connectors so now it charges. It's running much better now. Still popping a bit but think a run with some redex in should help. I have a screen that came with bike so may put that on. Any one got any stories about the screen. Does it make it better or worse?
  7. Hi all I have today purchased a dragstar 1100. After an awful ride home ( weather and bike problems) I am still excited and hasty with the purchase. I think a home service and carb clean and check we should be running smoothly! (Well that's what I am hoping!) This is my first cruiser type bike and even with all the problems on the journey home there were moments where I could see what the draw is. Comfortable and easy going. I think my sports bike days are well and truly behind me now.
  8. Thanks for the information! Was thinking a service may sort it. I have a haynes manual so looking forward to getting stuck in. I will head over to new members area now
  9. HI all. I have bought an 1100 dragstar today. Was really happy until the ride home. I noticed some back firing and general running issues. When I turned the choke off after. It should have warmed up it cut out. This happened all the way home. About a 45 minute drive in Terrential rain! Aswell as all this when it did cut out it was difficult to start. After about the 5th time the battery seemed flat. So I had to bump it. I finally got home and have put battery on charge. I bought it privately sold as seen. The people seem genuine but obviously there are issues. Hoping that a service and new battery may sort it. Any thought or advice welcomed.
×
×
  • Create New...