Jump to content

miller111106

Free
  • Content Count

    5
  • Joined

  • Last visited

Community Reputation

0 Neutral

About miller111106

  • Rank
    Member

Previous Fields

  • Current Bike(s)
    sachs roadster with a yamaha virago 125 engine
  1. hi here i am stuck again with another problem i cart get hold off a flywheel cover gasket for my 52 reg this engine is in sachs roadster can any1 help me find the rite part thanks andy
  2. check all pipes all ok but no fuel filter on bike . aswell do u no where the pipe on the inlet goes to
  3. hello everyone my bikes a sachs roadster with a yamaha virgo 125 cc twin v. i am haveing a problem with starting the bike things i ave done check plugs for spark remove carb and fully cleaned check all pipes or hole rips put new plugs in then i fitted it all back together got the bike to tick over a little bit but no revs then i notice it was only the rear engine working .so i removed front engine spark plug no fuel getting into it so i removed rocker cover to make the valves was working and there loads off compression so i put that back together then try to start again but nowt again can anyone help me . does any1 no wheres best place to get parts from thanks again andrew
  4. hello everyone my bikes a sachs roadster with a yamaha virgo 125 cc twin v. i am haveing a problem with starting the bike things i ave done check plugs for spark remove carb and fully cleaned check all pipes or hole rips put new plugs in then i fitted it all back together got the bike to tick over a little bit but no revs then i notice it was only the rear engine working .so i removed front engine spark plug no fuel getting into it so i removed rocker cover to make the valves was working and there loads off compression so i put that back together then try to start again but nowt again can anyone help me . does any1 no wheres best place to get parts from thanks again andrew
  5. hello everyone my bikes a sachs roadster with a yamaha virgo 125 cc twin v. i am haveing a problem with starting the bike things i ave done check plugs for spark remove carb and fully cleaned check all pipes or hole rips put new plugs in then i fitted it all back together got the bike to tick over a little bit but no revs then i notice it was only the rear engine working .so i removed front engine spark plug no fuel getting into it so i removed rocker cover to make the valves was working and there loads off compression so i put that back together then try to start again but nowt again can anyone help me . does any1 no wheres best place to get parts from thanks again andrew
×
×
  • Create New...